Please fix UI betting bug where buttons get disabled

Becomes your turn, you type in a custom value, you click min, and then try to click the half pot button but it’s disabled!?!. When you add the insane speed timer, it’s impossible to recover when you get into this state. The min, half and pot buttons should never become disabled during your turn. You should be able to toggle them all you want and have them reset any custom value when clicked. Having the UI get locked up like that has cost me so many times and so many chips.


I’ve noticed this happens when you don’t have enough for a min, half etc., call instead you will have to go all in to call the raise.

1 Like

I’ve been there and was very mad at myself for not truly deciding my bet

I’ve done the bet at a fixed bet wouldn’t take, rushed to make the 1/2 pot not available because I didn’t have enough chips and by the time I realized what I did to late for min bet. That’s why I was mad at myself.

1 Like

Yeah this is such a frustrating bug. I’ve seen it many many times, although its very rare - at least in my experience. I’ve tried to replicate this bug, but I’m not exactly sure how to. It seems to happen if you try to type an invalid bet size into the box. Very strange.

Most players just bet min, 50% 100% or all in - so most will prob never experience it.

The timer is irrelevant IMO bc once u get all actions disabled, its impossible to make any actions. Its not lag related IMO.

This glitch always catches me off guard and I never get a chance to screenshot it. I’ll go try and replicated it now, bc I’m bored!

1 Like

I was able to replicate the problem so I guess last time I tried I made very little effort! OFC there might be other issues and triggers too. I spent only 5 mins testing, maybe later I will test again if bored. I was testing on RIGHT table.

So if I enter an invalid amount of 999 that exceeds my bet limit, then lots of options are GREYED out and disabled and my only options are to FOLD or CALL.

YES! If our only options is to call or fold “WE” all lose a lot of chips as the recipient of this bug/glitch! This bug/glitch is induced by a human error, to try and bet more than possible - from my experience so far after testing. RP should not be “thrown off” and confused like a deer in the headlights after this human error and disable all options except FOLD or CALL.

This bug/glitch has been around for a long time. I haven’t experienced it in maybe months, I guess bc I haven’t made the mistake to induce it. Its surprising no one else has reported it.

I tested again. It seems after entering the invalid amount exceeding the bet limit, all the bet size buttons MIN, 1/2, POT & MAX work however the 'raise to" button is disabled meaning whilst the bet sizes still work they are effectively useless for that action in the hand.

FOLD & CALL still work (although effectively useless) whilst “RAISE TO” button is disabled.


1 Like

I have made a topic about it a year ago. Had the same problem at the time.
Raising more than stack

I don’t type the value in any longer. So this bug doesn’t bother me anymore.
It’s a bit sad that this still hasn’t been fixed.

I can only offer you a tip, that has been offered to me at the time. You can click right or left of the slider on the slider bar. That increases or decreases your bet by one big blind.


Hi Everyone,

Thanks for reporting this, and @DogsOfWar thanks for the screenshot. This has been relayed to our Tech Team for investigation.

In the meantime, @Erithacus provided a recommendation to move the slider the unlock the buttons. I just tried this work around and it works.


Unfortunately if very few players experience it, and very few players comment on the post then RP wont bother looking into the issue. TBF RP can’t address every post made on the FORUMs.

The issue has been around for much longer than a year.

Agree. When I experienced it I would be steaming broccoli on TILT like Phil Hellmuth. It made me so angry for a minute or so. Unfortunately & sadly I didn’t go test and try and replicate the issue.

My solution is be more careful with typing in bet size. I frequently bet specific sizes daily. I like to look at size of pot and/or bet sizes and bet accordingly. Its faster and easier to type bet sizes in many situations, IMO.

@chipsmama I don’t think @Erithacus was suggesting using the slider to UNLOCK the disabled buttons. I think @Erithacus was suggesting it as an alternative to using the bet box and typing. If it does work as a temporary FIX than this is great news that we can know what to do if it comes up. Thanks @chipsmama & prob let OP @graydwarf in on temporary solution.

Wait, let me understand the OP’s problem.

  1. you custom enter an invalid bet amount which is more than the amount of chips you have.
  2. the bet algorithm doesn’t allow your bet and greys out your bet options except to use the slider.
  3. the OP now wants Support to fix the UI to allow the betting option buttons to be Enabled when you’ve entered an invalid amount??

Do I need to go on because a simple solution is a change in the dealer chat message for everyone to see i.e.,

dealer: DogsOfWar, you’ve entered a bet which is more than your stack. Again!


Funny! :rofl:

Online poker isn’t live poker!

If I play live for 1/2$ and I have $2222 on the river and I said ALL IN for $222 222. Then the dealer looks at me and says: “sorry you :face_with_symbols_over_mouth: up big time! You only have $2222 so now your options are CALL or FOLD!”

Does that sound fair simply bc I made a stupid mistake?

As a basic summary from my testing to replicate this bug/glitch, YES! The player makes a mistake by trying to bet an invalid number and now the SYSTEM or RP panelizes the player.

I think its more noteworthy that @chipsmama provided a temporary fix, bc without this as @graydwarf said: “UI get locked up like that has cost me so many times and so many chips.”

Glad you took my post in the spirit I intended. Btw, it was interesting to know people have / can bet more than their stack because I’ve never done that.


I’m trying that in my next game for sure

Yes, totally, I get the joke! You would be laughing more if you were watching me frantically :face_with_symbols_over_mouth: :face_with_symbols_over_mouth: :face_with_symbols_over_mouth: bc i cant raise on the river with the nuts!

NO! Players can TRY to bet more than their stack. Its just a player mistake, typo etc. Its prob easier to do at higher stakes where on the river you might need to type in 555 000 and accidentally add an extra zero.

Its a rare mistake I make now. Last time was prob a few months ago. I was doing it more than weekly over a year ago.

1 Like

I’ve noticed this happen to me far too often, however I’ve always chalked it up to my internet crapping out and having to reconnect. If this is an issue entirely on Replay’s side, I should be entitled to back pay for the amount of chips lost because of this issue. Cause there have been many!