"Unable to reserve your seat" message/can't play

This is probably not the place to ask but I can’t sit at any table. Message I get is “Unable to reserve your seat Please try again”
Been playing sinc Dec 2020 and never had this issue. What can I do? Tks!

1 Like

Hi Lynn,
Would you mind sending details of the table or tournament in which you are having issues to support@replaypoker.com so the technical team can have a look at it.
Thank you, Kate

Hi Everyone!

This issue has been reported to our Tech Team. Can you please try to join another table and clear your browser cache if you’re still having issues?

We have listed the instruction on how to clear cache here: https://help.replaypoker.com/hc/en-us/articles/360002234394-Clearing-your-cache-

If you still cannot get on the table, please send us an email at support@replaypoker.com and provide the table you’re having issues with. Not everyone is affected, and our Team is looking into the tables that are getting errors.

Thank you for your patience.


Still will not let me on a ring game table…please fix

The same thing is happening to me today on all Abandon Ship and Spanish Main tables I cannot sit at any of them Please help. thank you!

I have the same problem

The talbes are doing this to me right now

I too am having this issue for the last hour or so. I’ve tried several different ring game tables at different stake levels. Have also sent a message to zendesk through Help feature.

Try another browser. I was on Firefox with this issue. No issue using BREVE or SAFARI.

1 Like

Try another browser. I was on Firefox with this issue. No issue using BRAVE or SAFARI.

I didn’t clear my cache…I just used a different browser (BRAVE) and issue wasn’t there. SAFARI also worked. It’s was just Firefox that had the bug for me.

I was playing Omaha hi/low in the ring games. The issue was the Firefox browser. I switched to BRAVE browser and no issue. Safari also works fine. Hope this helps!

I do not want to change browsers…I want this fixed…

Then may I suggest contacting the browser to correct the problem, Replay might not be able to help. Hope it gets fixed.

1 Like

Thank you, I thought it was just me.
Appreciate the advice. I’ll try everything out and get back to you

There is a problem with ring games in the past two days. It will not let me be seated by just joining, nor reserve a seat by clicking on the seat, nor let me join a waiting list. I am using the safari browser

I tried to join a SnG and got…

Sorry, you can’t register at this tournament because another player with the same IP address is already registered

I emailed support, but they don’t work weekends.

Relogging seemed to have fixed it.


Use Microsoft Edge.

Hi Everyone!

So sorry for the issues and thank you for your patience. Our Tech Team has deployed a fix. If you’re still having issues, please log out of your Replay account and clear your browser’s cache.

Tournaments will resolve the IP address issue as soon as 10 players register for the tournament. If you still can’t join a table after the troubleshooting steps above, please try to use another browser - we have tons of players who gave us feedback that doing so resolved the issue. If you’re still unable to join a table, please write in to support at support@replaypoker.com and indicate the table ID or table name you’re trying to join.

Thank you for your patience.

1 Like

That’s not much help if I’m trying to play a 9-max SnG.

Anyway, relogging cleared it for me, thanks.