The ENTER button isn't working!

The ENTER button isn’t working when I use it to place a bet like it previously did. Really frustrating!

I often like to type my bet using the NUM PAD into the bet box to easily make bets roughly at 25% 33% 66% 75% when Im not using the standard 50% or 100% button. It was very easy, fast n convenient to use the enter button to place the bet. Its now frustrating to have to manually click the bet button all the time.

Is this a change for the better or a glitch or why has it changed & been removed? Disappointed!

1 Like

Noticed the same. It’s kind of annoying tbh

1 Like

Thanks for the report - we’re looking into this one.

1 Like


I like me Enter button. :money_mouth_face:

I had the same issue yesterday - enter button isn’t working when I try to place a bet.

1 Like

Still isn’t working! It worked great before. I’m slowly adapting to this new limitation but its frustrating. I hope they fix it.

noticed this too

i like using the numb pad too

1 Like

Got some promising news from our tech team on this one, and should hopefully have the fix in within a couple of days. I’ll update if that changes.

1 Like


Just a quick update - still being worked on. The issue was identified, but is trickier than suspected to fix (thanks to some interference from the chat box). We hope to have this in soon, and the team should be able to look into it further once a fairly big project rolls out next week. :slight_smile:


This has now been fixed. Please let me know if it is still giving you trouble.


Yep - Enter key works again.

Thank you for looking into this fizzy - much appreciated.