Non arrival of ring game chips

I have tried other ways but no answer is there. So 3rd may i played sone ring game hands but tge chips did not go in to my activity. It has me plating just 2 hands and lost but i was up over 60k on the first i joined and i cant remember tge second.
I think what would be nice is for a link or thread straight to a moderstor or other so these issues can be solved.

I’m pretty sure it’s because of the maintenance problems that the website has had yesterday. A lot of problems everywhere. Give it some time, I think they will refund anything that you would have lost as a result of website issues. Try sending a message to Replay Support also, ideally with a screenshot of your most recent Transactions, it should display in there any obvious errors.

Hi notbadton, I do see that the credit went through in your account:

The best place to address this is via support, as we can’t share most account information here on a public forum, so I’m going to close this thread. If you’re still confused or have concerns, please shoot us a line at and we’ll follow up with you. :slight_smile: