New software failure

This is a new kind of freezing that started yesterday (9-10).

When a tournament starts, I click the play now button and a table opens up, but play is frozen I wait patiently a few minutes … meanwhile, at a totally different table, I’m being dealt cards, but since I’m not there, my stack is slowly being eaten away.

At last nights game, I was moved to another table, where I had to wait to be dealt in due to my proximity to the button. I didn’t think about it much since I only had to wait 2 hands tops before I’d be dealt in. After awhile, I notice that the table is frozen … on a hunch I hit [play now] … still frozen. So I closed the frozen table and hit [play now] … there I am at an entirely different table being blinded off.

Same thing happened tonight. I registered late so when my table opened, there was a hand in progress and everyone was waiting for one player to act, after a few minutes, it’s obvious that play is frozen, so I look in the lobby for the table that lists me and open it up … there I am, at two separate tables simultaneously, one frozen and the other one, I’ve timed out for how many hands, nobody knows?

I hope you can figure it out, because that’s not what poker players are looking for in a poker site.


this is kind of what happened to me. table I was at was froze, but I was watching lobby and notices chip counts being updated. I right clicked on my table and hit reload. table worked fine after that. wasted a 2.5K ticket

Have also noticed this. Had a similar problem a few times

  • Playing 250k sng
  • Went all in
  • Site appeared to freeze
  • Chat messages I posted didn’t appear (this is new, previously during freeze periods chat still worked)
  • Nothing happened for about 2 minutes
  • Was fast forwarded to the next hand in progress. I apparently had doubled up and missed the action.
  • In the next hand it was my turn to act. I clicked action button and nothing happened and I timed out. Other players were able to act.

After this the tourney info box in the bottom right corner doesn’t update.

I also noticed something interesting where it seemed a few players were timing out repeatedly. They would sit back in and time out again. Each time they would sit back in they would post an identical chat message.

Honestly this site is just getting worse by the day. I figure they’ve now introduced new bugs when trying to fix the old ones.


I will 2nd that 100%

1 Like

The same exact thing happened to me twice and on the 250k MTT. They refunded my entry fees for the 20 K MTT’s but not the 250k. It’s getting expensive to even log onto this site anymore let alone the frustration of wondering what’s going to happen next.
Why have had the " 50% off ALL Chip Packages" up for so long is even more Baffling !?!?!?!

1 Like

If i open a Ring-table, look to it and wait for a seat, then many times one minute later the table is frozen. But, what wonder, on Lobby the playing on this table goes on. Peoples leave, new comes to table, stacks changes.
If i join a table then it freezes too, but the other players playing on this table is going on. I lose my blinds, sit out or lose my seat.
Right click to table and load new helps. But what a playing is this?
Not good, what Google there made, they must do this better.

1 Like

[quote=“unskilld, post:3, topic:34444”]
Chat messages I posted didn’t appear (this is new, previously during freeze periods chat still worked
) If chat does not work then you need to immediately back out and reboot or hit the play now button. Works for me. If chat works stick around.

1 Like

One problem I haven’t seen mentioned is there have been a few times these last few weeks, when I was moved to a new table in an MTT, but the old table stays open (I just disappear from it). I then have to find my new table from the lobby, because it doesn’t automatically redirect me to it. I’ve only had it happen a few times, and they weren’t nights where freezing was an issue, so I figured it was just another bug on the new tables. Some things have never worked right on MTTs since they upgraded from flash.


That has happend to me too a few times,but that has been from 2019 i started here!

1 Like